
Introduction MATRISIntroduction MATRISIntroduction MATRISIntroduction MATRIS 

The purpose of the application is to collect technical information about VOLVO Construction 
Equipment’s products in use and present the information to the operator, and forward it to 
certain sites, as the main office of VOLVO Construction Equipment. 

The information is accumulated and stored in the ECUs (processor) of a machine during the 
life cycle of the machine. The process of collecting information is called reading. 

The processing of the information into compiled presentation material in the PC gives a 
comprehensive understanding about the usage and the quality of the machines.  

A reading can be handled in the functions of the MATRIS application.  

� Reading  
� Analysis  
� Search  
� Export  
� Service Display  
� Alarm  

Main WindowMain WindowMain WindowMain Window 

The Main Window is the first window that meets the operator when starting the MATIS-
application. 

The main window holds: 

� A menu with dropdown menus.  
� A Toolbar with icons.  
� A welcome picture.  
� A Button bar with one button per function.  

The button bar is only shown in the Main Window. When the operator clicks a button, the 
corresponding Function Window opens. 

ToolbarToolbarToolbarToolbar  

The Toolbar in MATRIS is placed in the top area of the windows. The toolbar contains icons 
which are uncoloured (grey) when not useable. By clicking a icon an application function 
occurs, mostly by the opening of a new window.  
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The icons have the following functionality when clicked:The icons have the following functionality when clicked:The icons have the following functionality when clicked:The icons have the following functionality when clicked:  

The icon CLOSE shuts down the function windows and takes the operator back to the 
main window of the application 

The icon EXPORT TO FILE opens a dialog window which makes it possible to export 
one or all readings to a file that will be saved on a selected directory. 

The EXPORT TO SERVER icon opens a dialog window which makes it possible to 
export readings to another site via net facilities for example via modem. 

The SEARCH icon opens the Search Window where performed readings can be 
selected for viewing and/or analysis. 

The READING icon opens the Reading Window from which a reading can be performed 
or viewed. 

The INDIVIDUAL ANALYSIS icon opens the Analysis window in individual mode, in 
which a reading is presented in diagrams and grids. 

The TREND ANALYSIS icon opens the Analysis window in trend mode, in which three or more 
readings for the same machine can be compared.  

The DIFFERENTIAL ANALYSIS icon opens the Analysis window in differential mode, in which 
two readings for the same machine can be compared.  

The FLEET ANALYSIS icon opens the Analysis window in fleet mode, in which readings for 
machines of different models can be compared.  

The SERVICE DISPLAY icon opens the Service Display, which shows the status of the 
current operating machine. The icon will not be visible and cannot be used on MATRIS 
Customer version 
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The READING NOTE icon opens the reading note window. 

The PRESENTATION NOTE icon opens the presentation note window. 

The EDIT ALARM RULE icon opens the edit part of the alarm function. From this window 
it is possible to manage alarm rules. 

The TRIGGERED ALARMS icon opens the window where new alarm rules can be 
created. 

The RELEASE PRESENTATION icon opens a new window containing the current 
presentation so that multiple presentations can be compared side to side.  

The AVERAGE PRESENTATION icon adds an average value bar to the current graph. The 
average value is calculated from other readings for the same machine model in the local 
database.  

The FAULT CODES icon opens a window containing all ECU fault codes stored in the current 
reading.   

The EXPLANATION icon opens an explanatory text (and picture) concerning diagrams in 
the Navigator of the Analysis Window. 

The HELP icon opens the MATRIS Help Documentation. 

Window ComponentsWindow ComponentsWindow ComponentsWindow Components 

The following components are used in the MATRIS’s application windows. 

 A field with white background color can be entered by the operator. The 
operator can fill in information in a blank field or alter information in the field. 

 A field with grey background color can not be enteredcan not be enteredcan not be enteredcan not be entered by the operator. An 
empty field will normally be filled in automatically when the operator performs a reading. 
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A field with white background color and an arrow to the right of the field is called a drop downdrop downdrop downdrop down 
field. The operator can fill the field in or change the information in the field by clicking the arrow 
and select an item in the shown list. The picture below shows a dropped down list.  

 Components as shown beside are called buttons. When the operator 
clicks a button a command connected to the button is performed. A button with grey text is not 
active and can not perform a command. 

 Blue circles are found in the Equipment Window when the Hotspot text is hidden. 
The circles are called Hotspots and shows where a certain equipment is situated on a machine 
model.  

 The Hotshot text is shown in hotspot fields in the Equipment Window . 
When the operator clicks the field a list with possible choices for the equipment type is shown.  

Reading InformationReading InformationReading InformationReading Information 

In the most upper part of the MATRIS Windows information is given about which window the 
operator visits and in appropriate cases, about the current reading. 
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The blue bar above holds information that the current window is the Reading Window and the 
current reading concerns a machine with the model identification L180 and the serial number 
1040.  

UserUserUserUser Preferences Preferences Preferences Preferences 

.   

The User Preferences dialog lets the operator: 

� Change current Company.  
� Change current Operator name.  
� Change language for the MATRIS application.  
� Activate correct COM port for reading  
� Decide which unit system to use. You can only use US units together with English 

language.  
� Specify when to performe alarm calculations  

The system restarts automatically if there has been changes in the User Preferences. 

PrintPrintPrintPrint 

The File menu contains the item print. When the operator clicks the print item four more items 
are available. 

� PrintPrintPrintPrint screenscreenscreenscreen - prints the current screen  
� Print DiagramPrint DiagramPrint DiagramPrint Diagram - prints the current diagram in the Analysis Window.  
� Print Diagram and expl. textPrint Diagram and expl. textPrint Diagram and expl. textPrint Diagram and expl. text - prints the current diagram and explanation text in the 
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Analysis Window.  
� Print Search ListPrint Search ListPrint Search ListPrint Search List - prints the search criteria and the result from a search made in the 

Search Window.  
� Print Analysis ReportPrint Analysis ReportPrint Analysis ReportPrint Analysis Report - prints a report from current or selected readings. The list shows 

all diagrams and equipment. (If two readings with the same model and serial number are 
selected, the equipment from the latest performed reading is listed.)  

� Print Analysis Report and expl. textPrint Analysis Report and expl. textPrint Analysis Report and expl. textPrint Analysis Report and expl. text - prints a report and explanation text from current or 
selected readings.  

� Print Machine InformationPrint Machine InformationPrint Machine InformationPrint Machine Information - prints a list shows machine information and equipment.  
� Print Customizable ReportPrint Customizable ReportPrint Customizable ReportPrint Customizable Report - offers an easy way to produce, package and customize a 

reading analysis. This report is based on the reading that is active when it is created and 
can be customized in the following ways:  

� Use the selection function to decide what presentations to include in the report. If 
no selection is done all presentations will be included.  

� Use the reading note function to include a general comment in the report.  
� Use the presentation note function to comment the presentations that are included 

in the report.  
� Use the report dialog to add dealer name, issuer, site and a picture (several 

formats are supported).  

It is possible to print out all suggestions that are mentioned above as PDF file. Change the 
print set up to PDF writer. 

The computer has to be installed with Adobe Acrobat Writer or PDF Creator to be able to print 
as PDF.  

MenusMenusMenusMenus 

The Menus in MATRIS is situated in the top area of the windows. The Menu Items are 
uncolored (grey) when not useable. In the main Menu you can select a menu Item by pressing 
the underscored character together with the ALT-key. (For example ALT + F + U to reach User 
Preferences under the File Menu.) 

  

When dropped down some Menu Items have further items which are possible to select by 
clicking the item. (Se Print item in the File Menu). 

File menuFile menuFile menuFile menu 

The file menu contains items that is basic for the MATRIS application  
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� The CloseCloseCloseClose item closes Functions and windows. The operator returns to the main window 
of MATRIS.  

� The item SaveSaveSaveSave is active whenever a reading or a change to a reading has been done in 
the Reading - and/or Equipment Window . The Save-command saves data to MATRIS’s 
database.  

� The DeleteDeleteDeleteDelete item is active when looking at a reading in the Reading Window or if one or 
more exported readings are selected in the Search Window. The Delete-command 
deletes a reading from MATRIS’s database.  

� The Start ReadingStart ReadingStart ReadingStart Reading item is active when entering the Reading Window . The Start Reading 
command starts the transfer of data from a machine to the MATRIS application.  

� The Import export file item makes it possible to import earlier exported files.  
� The Export item makes it possible for the operator to export readings to a another site 

and/or to a folder on disk. When clicking the Export item a dropdown menu opens with 
possibilities to select Export server and Export File .  

� When clicking t the Print item, a dropdown menu opens with possibilities to select 
different print options.  

� The Print SetupThe Print SetupThe Print SetupThe Print Setup item gives the operator opportunity to select a printer.  
� The User PreferencesUser PreferencesUser PreferencesUser Preferences item opens the User Preferences.  
� The ExitExitExitExit item shuts down the application.  
� The last item on the file menu is a history listhistory listhistory listhistory list that shows the five last readings that have 

been done. The readings model, serial number and working hours are shown to identify 
the readings.  

Edit MenuEdit MenuEdit MenuEdit Menu 

 

The Edit Menu has the following options CutCutCutCut, CopyCopyCopyCopy and PastePastePastePaste. These options have the same 
function as in Windows 95/98.  
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Their shortcut-keys are shown beside the menu items. 

The option Copy Graph to ClipboardCopy Graph to ClipboardCopy Graph to ClipboardCopy Graph to Clipboard is used to copy the graph to another program such as 
Word, Excel or PowerPoint.  

The Reading NoteReading NoteReading NoteReading Note and Presentation NotePresentation NotePresentation NotePresentation Note options are used to edit the notes tied to the current 
reading or currently displayed presentation.  

View MenuView MenuView MenuView Menu 

  

  

The View Menu holds items that are activated when the operator enters the Analysis window  

� NavigatorNavigatorNavigatorNavigator -Whenever the Navigator is checked the Navigator is visible in the window.  
� GridGridGridGrid -Whenever the Grid is checked the grid is visible in the window.  
� ExplanationExplanationExplanationExplanation - Shows an explanatory text to the current diagram in a dialog Window.  

When both Navigator and Grid are unchecked, the diagram covers the whole window. 

Function MenuFunction MenuFunction MenuFunction Menu 
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The Function Menu takes the operator of MATRIS to the different function windows. The 
operator can either user the icons or the Function Menu items to navigate in the MATRIS 
application.  

The Items in the menu are uncolored (grey) when not usable. (This goes for the icons in the 
Toolbar as well). 

� Reading - Takes the operator to the Reading Window  
� Individual Analysis -Takes the operator to the Analysis Window in individual mode  
� Trend Analysis -Takes the operator to the Analysis Window in trend mode  
� Differential Analysis -Takes the operator to the Analysis Window in differential mode  
� Fleet Analysis -Takes the operator to the Analysis Window in fleet mode  
� Service Display - Shows the Service Display for the current connected machine.  
� Fault Codes - Shows the Fault Codes of the current reading.  
� Search -Takes the operator to the Search Window  
� Edit Alarm Rule – Takes the operator to the Edit Alarm Rule Window  
� New Alarm Rule – Takes the operator to the New Alarm Rule Window  
� View Triggered Alarm – Display all defined alarm which have been triggered.  
� Make New Selection -Display panel to make a new selection  
� Show Selection -Display panel for available selections  
� View All Diagram -Display all graphs. Standard mode  
� Expand/Collapse Navigator Bar -View all presentations or view only the folders  
� Remove Inactive Customer -Remove customer name that haven’t got a reading 
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connected to it  
� Release Presentation -Opens a new window containing the current presentation so that 

multiple presentations can be compared side to side.    
� Average Presentation -Adds an average value bar to the current graph. The average 

value is calculated from other readings for the same machine model in the local 
database.  

Tools MenuTools MenuTools MenuTools Menu 

  

  

The Tool Menu is active when the operator enters the Equipment Window. 

� ZoomZoomZoomZoom - When checked the left mouse button serves as zoom in tool and the right button 
as zoom out tool.  

� Show all equipment Show all equipment Show all equipment Show all equipment ---- when the operator unchecks the item all equipment information is 
hidden. The Hotspot circles is left but all text information is hidden.  

Help menuHelp menuHelp menuHelp menu 

  

  

General help information is reached when the help icon or from the Help Menu and choose 

Contents.   

Specific help topics are reached by means of the help buttons in dialog windows. 

The latest Up-Date information is located in the menu Up-Date info. 

Possibility to send email, from MATRIS to the Customer Support Software Helpdesk. 
Automatically opens a new email 
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AnalysisAnalysisAnalysisAnalysis 

The Analysis Function will make it possible to analyze information about individual machines.  

The information from readings is processed and presented per function group as diagrams and 
in tabular form. 

The analysis is based on one or several performed readings. 

The Average Presentation function (found in the menu and in the toolbar) can be used to 
compare the selected readings with an average calculated from other readings for the same 
machine models. This function is only available when connected to the local database. If the 
database contains a large amount of readings, not all of them might be used for calculating the 
average.  

Individual AnalysisIndividual AnalysisIndividual AnalysisIndividual Analysis 

Individual analysis is performed when one reading is selected in the Search Window. 
Diagrams and tables are used to illustrate the performance caught in an individual reading. 

Comparison AnalysisComparison AnalysisComparison AnalysisComparison Analysis 

Comparison analysis is used to illustrate the utilization of the vehicle between two separate 
occasions (readings). 

Trend AnalysisTrend AnalysisTrend AnalysisTrend Analysis 

Trend analysis is a tool for tracking of machine performance over time. Line diagrams are 
utilized for analysis of many readings in one single presentation. Each marker represents a 
reading and the reading dates are listed on the X-axis.  

The graph contains two lines. The first one shows the average value over the machine's 
lifetime. The second one shows the average value since the previous reading.  

In the following example, the machine has been started on average 2 timers per hour between 
2003-03-26 and 2003-04-11. The average number of starts during the machine's lifetime is 8.  
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Fleet AnalysisFleet AnalysisFleet AnalysisFleet Analysis 
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Fleet analysis makes it possible to analyze readings from different machines. The analyzed 
readings can be from different models and different product ranges. The selected readings are 
presented in different colors and can easily be compared. 

The Analysis windowThe Analysis windowThe Analysis windowThe Analysis window 

 The Analysis Window is reached by clicking the Analysis icon or from the Function 
Menu . To get access to the Analysis window a reading must be current.  

The operator has either selected a reading in the Search Window or just performed a new 
reading (the reading must be saved to the database) when he enters the Analysis Window. 

The most upper blue ribbon of the Analysis Window holds the information about the current 
readings. Here the model, serial number and operating hours are found. If two readings with 
the same model and serial number have been selected in the Search Window the ribbon holds 
information about the operating hours from both occasions. If three or more readings have 
been selected the upper ribbon holds information about model and serial number (no 
information if the selection is a fleet). 

The diagrams can be printed either one at a time or a list containing information about current 
reading (readings if two or more readings are selected) including all diagrams. 

The Analysis Window consists of three parts: 

� Navigator  
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� Diagram Viewer  
� Grid Viewer  

NavigatorNavigatorNavigatorNavigator 

  

The Navigator makes it easy to select diagram subjects to be shown in the nearby situated 
Diagram Viewer. Under each function group the diagram subjects are found.  

  

� When clicking a subject row a diagram opens which reflects the current reading.  
� When double clicking a Function group row it expands or collapses due to the previous 

situation.  
� When clicking a Function group a picture of the current model is shown.  

When a reading contains some invalid values and the operator clicks the corresponding 
diagram subject the dot on the subject row turns red to indicate invalid data. 

A special "notes icon" is displayed next to the bullet for those presentations that contain a 
presentation note.  

Enlarging the Navigator Enlarging the Navigator Enlarging the Navigator Enlarging the Navigator  

� The Navigator can be enlarged. By placing the cursor on the left or bottom margin till the 
symbol  is shown. Keep the left mouse button pressed and drag the margin to the 
desired size.  

� The Navigator can be hidden by unchecking the Navigator item in the View Menu..  

Diagram ViewerDiagram ViewerDiagram ViewerDiagram Viewer 
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The Diagram Viewer shows diagram according to selected subjects in the Navigator. The 
Diagram may have an Explanatory text (and picture) concerning the current diagram. To show 

the Explanation, click the corresponding icon in the toolbar .  

Enlarging the Diagram ViewerEnlarging the Diagram ViewerEnlarging the Diagram ViewerEnlarging the Diagram Viewer 

� The Diagram Viewer can be enlarged. By placing the cursor on the left or bottom margin 
till the symbol  is shown. Keep the left mouse button pressed and drag the margin to 
the desired size.  

� The Diagram Viewer can cover the whole window through unchecking the Navigator and 
the Grid in the View Menu. .  

ExplanationExplanationExplanationExplanation 

The Explanation Dialog holds information about the current diagram subject. The dialog closes 
down when the button Close is clicked. 
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Grid ViewerGrid ViewerGrid ViewerGrid Viewer 

  

The Grid Viewer shows the figures behind the diagrams. The grid is only shown in user level 2. 
User Level 2.. 

When marking a column or a row it is possible to copycopycopycopy the information in paste it into another 
Windows application. Use the copy command in the Edit Menu.. 

Enlarging the Grid ViewerEnlarging the Grid ViewerEnlarging the Grid ViewerEnlarging the Grid Viewer 

� The Grid Viewer can be enlarged by placing the cursor on the left or upper margin till the 
symbol  is shown. Keep the left mouse button pressed and drag the margin to the 
desired size.  

� The Grid can be hidden by unchecking the Grid item in the View Menu. .  

How to analyze a readingHow to analyze a readingHow to analyze a readingHow to analyze a reading 

1. The operator enters the Analysis Window either from The Reading Function or the 
Search Window.  
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2. The operator selects a diagram subject by clicking the subject.  
3. A diagram for the selected subject is shown in the Diagram Viewer and the 

corresponding figures are shown in the Grid Viewer.  
4. The Operator chooses eventually other diagrams subjects.  
5. The operator leaves the Analysis window by: 

� closing the window by clicking the Close icon  
� entering the Search Window by clicking the Search icon  
� entering the Reading Window by clicking the Reading icon.  

SelectionSelectionSelectionSelection 

New Selection can be used to display all presentations, such as on a customer visit. To make 
a new selection a reading must be active and the analysis window brought up. Choose 
Function-Make new selection 

  

The selected model is displayed in the upper left-hand window. 

Deselect the presentations which will not be displayed and save the selection in the field Save 
selection as. Click OK and the selection is activated. 

The current selection is displayed in the upper right-hand corner. 
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It is possible to save several different selections per model. 

Correct machine model in the analysis mode is required to activate the selection 

  

Choose the selection to be displayed and click OK. 

The correct machine model in the analysis mode is required to activate a previously saved 
selection. 

Choose Function - Show selection, to see available selection and to make a choice. 

To delete a selection the selection must be marked. Click on the Delete selection button. 

Finish by clicking on OK 

To return to the standard mode, where all presentations are displayed, choose Function-View 
all diagrams 

Merge readingsMerge readingsMerge readingsMerge readings 

Two readings from the same machine can be merged and saved as one. In other words, a 
comparison analysis can be stored in the local database. There are who ways to merge 
readings: 

� Choose “Save analysis” in the “Function” menu when a comparison analysis is 
performed.  

� Choose “Save analysis” in the “Function” menu when two readings from the same 
machine are highlighted in the search window.  
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 A merged reading has two reading dates and two operating hours. 

NotesNotesNotesNotes 

 Two types of notes can be created, reading notes and presentation notes. 

 A reading note is a piece of text tied to a specific reading. There are three ways to create a 
reading note: 

� Choose “Reading note” in the “Edit” menu when a reading is active or highlighted in the 
search window.  

� Click the reading note button when a reading is active.  
� Use the note field in the reading window.  

 A presentation note is a piece of text tied to a specific presentation in a reading. Hence, a 
reading can have many presentation notes. When a presentation is displayed the presentation 
note function can be activated in two ways: 

� Choose “Presentation note” in the “Edit” menu.  

� Click the presentation note button.  

 Notes can not be created when more than one reading is active or selected in the search 
window. 

 Notes play an important role when reading reports are created. 

Reading Reading Reading Reading  

The reading function will make it possible to collect information from the ECU of a individual 
machine and store the information in a local database on the PC. 

To perform the reading the operator connects a portable PC to the ECU of a machine.  

Known information about the machine individual is eventually provided on a CD-ROM to 
support the operator. For example processed information from the machine card. 

There are two reasons to entering the Reading Window. 

� Perform a new reading.   
� Perform a new wireless reading.   
� Review a previous reading.   

The Reading Function consists of two windows. 
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� The reading Window  
� The Equipment window  

The Reading windowThe Reading windowThe Reading windowThe Reading window 

 

There are tree ways of entering the Reading window 

� From the Main Window to do a new reading  
� From the search window.  
� From the Analysis Window.  

New ReadingNew ReadingNew ReadingNew Reading 

To perform a reading the operator must first select the type of connection to the ECU. For USB 
and Serial port connections, the type of cable can optionally be selected using the radio 
buttons in the upper right corner of the reading window. If Automatic Automatic Automatic Automatic is selected, MATRIS will 
try each cable type in turn. 

If a 88890020 device is used for reading, it's also possible to connect to the ECU using WLAN. 
In this case, the cable selection radio buttons have no meaning and the reading should be 
started using the WLAN ReadingWLAN ReadingWLAN ReadingWLAN Reading button.     

How to do a wireless reading. 

To start a normal (non wireless) reading, the operator clicks the Start ReadingStart ReadingStart ReadingStart Reading button. 

When to reading starts, a dialog window opens which shows that a reading is in progress. 
When the Progress Bar is full blue, the reading is ready. 
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During the reading the operator can Cancel the reading by clicking the Cancel button. 

When performing a new reading several fields will be filled in automatically. The missing data 
must be completed by the operator. All fields except Workorder and Note are mandatory.All fields except Workorder and Note are mandatory.All fields except Workorder and Note are mandatory.All fields except Workorder and Note are mandatory. 

When all fields are filled in the operator continues the registration of the reading by continuing 
to the Equipment Window and register the current equipment for the machine, thereafter the 
reading can be saved to the database by clicking the Save button which now is active.  

A reading can be deleted by the Delete item in the File Menu..  

How to do a reading. 

Undercarriage Wear Inspection CardUndercarriage Wear Inspection CardUndercarriage Wear Inspection CardUndercarriage Wear Inspection Card 

This feature is only available for crawled excavators.  

When undercarriage wear inspection is carried out, it's possible to enter the measurements 
into a form in MATRIS and save it as part of a reading. The inspection result can then be 
reviewed using MATRIS and exported to other systems.  

The MATRIS database contains information about the standard measurements of varous 
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components (the measurement when the component is new) and the limit at which the 
component will need to be replaced. When an entered measurement is below the minimum 
limit, the wear is over 100% and the component will be highlighted with a red background 
colour. 

The inspection card contains functionality to estimate when (at what operating hour) a certain 
component will have to be replaced. This calculation is based on the measured wear 
percentages and the current operating hours of the machine.  

Restored Reading.Restored Reading.Restored Reading.Restored Reading. 

If the operator closes the Reading Window without continuing to the Equipment Window the 
current reading is restores the next time the operator enters the Reading Window. This holds 
even if the operator has left the MATRIS application. 

This behavior allows the operator to complete a reading at a later occasion.  

Review a readingReview a readingReview a readingReview a reading 

To review a earlier done reading the operator enters the Reading Window from the 
Search_Window after having selected one reading. 

If the reading have not been exported, the operator can change the information in the white 
colored fields and save the changes to the database by clicking the Save Button. 

How to review a reading. 

Delete a readingDelete a readingDelete a readingDelete a reading 

A reading can be deleted if not exported.    The operator clicks the Delete item    in the File Menu 
and the current reading is deleted. 

To delete several readings see 4.3.1. Search Window. 

How to do a ReadingHow to do a ReadingHow to do a ReadingHow to do a Reading 

1. Switch the machine on, ignition key on.  
2. The operator connectsconnectsconnectsconnects a laptop PC to the machine, with the MATRIS program open.  
3. The operator clicks the Reading icon/Reading buttonReading icon/Reading buttonReading icon/Reading buttonReading icon/Reading button in the Main Window and the 

Reading Window opens.  
4. The operator clicks the Start Reading buttonStart Reading buttonStart Reading buttonStart Reading button and a signal is sent from the PC to the 

machine which gives the ECU in the machine OK to start sending information. The ECU 
in the machine sends the information to the PC where it is interpreted and stored.  

5. Transferred informationinformationinformationinformation about the machine is shown is shown is shown is shown in the fields on the screen. The 
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reading date is set from the PCs system date and can not be changed. If Sales Model, 
Serial number and Operation hours are automatically filled in there is no possibility to 
change this.  

6. The name of the operator is filled in automatically according to the name given when 
setting up the application. The operator    can change the name if it is wrong change the name if it is wrong change the name if it is wrong change the name if it is wrong.  

7. The operator fills in missing identifying informationfills in missing identifying informationfills in missing identifying informationfills in missing identifying information in the fields on the screen. The 
operator has access to choice of country, primary applications and customers. To receive 
more detailed description of the primary application, click on the icon to the right side of 

the field.  

The Customer field is context sensitive. The operator can fill in a customer which is not in 
the list , this will add a new customer to the list as well as register the new customer for 
the current reading. 

8. The operator continues to the Equipment Window by clicking the Equipment button.clicking the Equipment button.clicking the Equipment button.clicking the Equipment button. The 
Equipment window opens  

Continue by reading chapter  How to register equipment  

How to review a readingHow to review a readingHow to review a readingHow to review a reading 

1. From the Main Window click the Search iconSearch iconSearch iconSearch icon or the Search buttonSearch buttonSearch buttonSearch button. The Search Window 
opens.  

2. Fill in the appropriate Search criteria Search criteria Search criteria Search criteria in the Window.  
3. Click the Search buttonSearch buttonSearch buttonSearch button to left of the search criteria to complete the searching.  
4. The result of the performed search is shown in the grid at the bottom of the window.  
5. Select one or several of the readings by clicking at the appropriate rows.  
6. Decide whether the reading should be analyzed, or if the basic reading information 

should be shown. (Does not work with choice of two or more readings) Click either the 
icon Analysisicon Analysisicon Analysisicon Analysis to open the Analysis Window or the icon Readingicon Readingicon Readingicon Reading to open the Reading 
Window.  

Continue by reading chapter  How to analyze a reading  

Equipment WindowEquipment WindowEquipment WindowEquipment Window 

The Equipment window is reached by using the Equipment button from the Reading window.  

The main equipment of a machine at the reading occasion is registered in the Equipment 
Window. 

The Equipment Window consists of a schematic picture of the sales model. In the picture there 
are numbered hot spots. For each hot spot it is predefined which type of equipment the hot 
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spot concerns.  

The hot spots are connected to fields containing equipment type and their individual 
description. The information about equipment for individual machines is stored in a database. 

When the operator clicks a hot spot, a popup equipment box will show a list in which the 
possible choices of equipment for the out pointed hotspot. The items in the list are specific for 
the hot spot type and the sales model. 

  

If the database holds information about the equipment for the current machine, it is connected 
to the appropriate hot spot and the corresponding fields are filled in automatically. The 
operator checks and corrects the existing hot spots and completes the information for those 
hot spots that are not filled in. 

In the Tools Menu there is a item Show all equipment which hide and shows the hot spots if 
checked and unchecked. 

 How to register Equipment 

How to register EquipmentHow to register EquipmentHow to register EquipmentHow to register Equipment 

1. The operator enters the Equipment Window from the Reading Window.  
2. If the database holds information about the equipment of the machine, this information is 

automatically filled in.  
3. The operator checks the current Equipment of the machine.  
4. The operator makes appropriate changes of the given information.  
5. The operator checks if there are more Equipment items on the current machine and adds 

equipment information in case it is relevant. As help a list of valid items occurs when 
clicking the left mouse button in the Equipment type field.  

6. The information is saved to the database when the operator clicks the Save button either 
in the current window or in the Reading window.  

7. The operator continue by: 
� Closing the Window and returns to Main Window.  
� Continues to the Analysis Window.  
� Continues to the Search Window to pick a reading to review.  
� Returns to Reading Window.  
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Continue by reading chapter  How to analyze a reading. 

Continue by reading chapter  How to review a Reading. 

SearchSearchSearchSearch 

The Search function makes it possible to search for specific readings and examine the 
information that has been registered in the reading operation. 

The basic information that is registered in connection to the reading operation can be viewed 
and altered (if not exported) in the Reading and Equipment Windows.  

Further more, analysis of different reading subjects are presented in diagrams and grids in the 
Analysis window. 

The Search WindowThe Search WindowThe Search WindowThe Search Window 

  

The Search window is used to select readings, which information then will be shown by means 
of the Reading window or the Analysis Window. From the Search Window the operator has the 
opportunity to continue to those windows to examine the reading information. 

The Search Window consists of two parts: 

� Search criteria  
� Search Result list  

Delete one or several readings Delete one or several readings Delete one or several readings Delete one or several readings  

One or several readings that are exported can be deleted from search window. The operator 
selects the reading(s) to be deleted. Several readings can be selected at the same time by 
using the CTRL key. Choose File - Delete 

Criteria for searchCriteria for searchCriteria for searchCriteria for search 

The available search criteria are Product range, Sales model, Serial number, Customer and 
From reading date, To reading date. 

The Search Button to the right performs the search when clicked. 

The Clear Search button clears the fields in the Search Criteria box and the Search Result list. 
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The behavior of the search criteria is as follows:The behavior of the search criteria is as follows:The behavior of the search criteria is as follows:The behavior of the search criteria is as follows: 

� The criteria can be combined, different criteria can be used in the same search 
operation. Some combination are not logical.  

� If a Product range is specified the drop down field for Model will contain models within 
the selected Product range.  

� If the Serial Number is known, there is no meaning to specify Product group and Model.  
� The dates can be given one by one or as a interval.  
� The Customer field has a dropdown field which gives the opportunity to choose among 

the existing customer names.  
� The customer field is context sensitive. If a letter is typed in the field, a customer which 

name begins with the letter appears in the field (if there is one in the database).  
� With no criteria given the grid shows all readings in the database. (Not recommended, if 

many readings are stored in the database)  

When the desired criteria has been filled in and the Search button is clicked, the search List is 
filled with the readings that corresponds to the given criteria. 

The Search ResultThe Search ResultThe Search ResultThe Search Result 

When the Search button is clicked the result of the search is shown in the grid at the bottom of 
the Search Window.  

To the right in the bottom of the window the number of hits in the current search are shown. To 
sort a column ascending or descending, click once on the appropriate column heading. 

� One or several readings can be selected in the grid for further examination.  
� To make one selection of a reading, click the desired row.  
� To make more than one selection among the readings, press ctrl-key and click the row 

simultaneously.  
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One reading selectedOne reading selectedOne reading selectedOne reading selected 

� The reading can be shown in the (Individual) Analysis Window as diagrams and figures.  
� The basic information about the reading can be viewed in the Reading Window and the 

Equipment Window.  
� If the reading is not exported, the basic information about the reading can be changed in 

the Reading Window and the Equipment Window.  

Two or more readings selectedTwo or more readings selectedTwo or more readings selectedTwo or more readings selected 

� If two readings with the same model and serial number are selected the Differential 
Analysis function will be available.  

� If three or more readings with the same model and serial number are selected the Trend 
Analysis function will be available.  

� If two or more readings with different serial numbers and models are selected the Fleet 
Analysis function will be available.  

� The Reading Function can not be reached when two or more readings are marked.  
� The Exp column in the grid shows if the reading is exported or not.  

ExportExportExportExport 

         

The result of a reading is stored in a local database. When the operator connects the PC to 
some means of communication, for example a modem, the readings could be transferred to a 
main database at the production company  . It is also possible to export reading to 
directories on disk .  

� Export to Server  
� Export to File  

Server Export WindowServer Export WindowServer Export WindowServer Export Window 

 The operator is recommended to export readings at regular intervals. The PC must be 
able to communicate with the receiving site (for example via Internet or modem). The operator 
selects the addresses of the receivers and clicks the OK button to start the export. 
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Export when open MATRISExport when open MATRISExport when open MATRISExport when open MATRIS 

If there are readings that are not exported, a message will be shown when open MATRIS 

 

� Click ‘Yes’ and the Server Export Window will open. Connect to Internet and select OK 
and the readings will automatically be send to the main database.  

� Click ‘Later’ if there is nononono connection to Internet or if the readings will be send another 
time  

Update addressesUpdate addressesUpdate addressesUpdate addresses 

� In the box Select fromSelect fromSelect fromSelect from the available IP-addresses are shown.  
� In the box Export toExport toExport toExport to the current receiver addresses are shown.  
� To move an address to the Export toExport toExport toExport to box, the desired address should be marked and the 

button with a right arrow clicked.  
� To add a new address the operator adds the new IP-Address in the box Add new ServerAdd new ServerAdd new ServerAdd new Server 

in the lower part of the window and clicks the Add button. (All the fields must be filled in.) 
The new address is added in the Select fromSelect fromSelect fromSelect from box.  
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The application remembers the last Export to Export to Export to Export to addresses when the operator leaves the 
application till the next time he enters. 

The addresses can be deleted with the exception of the default address to the main site. 

If there are disturbance in the communication the operator will receive a message. 

When a reading is exported there is not possible to change any reading data thereafter.  

In the Search window the operator can see if a reading has been exported by looking in the 
search result grid. . 

How to export to serverHow to export to serverHow to export to serverHow to export to server 

1. The operator prepares the PC for communication (connects to Internet or a modem)  
2. The export starts when the operator clicks the OK button.  
3. The MATRIS program export all unexport readings.  
4. A dialog appears and a colored bar will be filled as the export goes on.  
5. The operator can cancel the export by pressing the Cancel button.  
6. The dialog shuts down and the export is ready.  
7. The readings, which have been exported to a server, are marked in the local database 

and can not be altered later.  

File ExportFile ExportFile ExportFile Export 

 This function gives opportunity to save readings to files in a selected directory. The 
operator decides whether all readings or only the current reading should be exported by 
checking the appropriate radio button.  

The operator selects the driver and folder into which the readings should be exported. When 
OK button is clicked the export starts.  
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How to export to fileHow to export to fileHow to export to fileHow to export to file 

1. The operator clicks the icon Export to file or the corresponding item in the file/Export 
menu.  

2. A dialog window opens  
3. The operator selects to which folder the files should exported  
4. The operator selects if all readings should be exported or only the current.  
5. When the OK button is clicked the export begins.  

ImportImportImportImport 

The Import function makes it possible to import raw reading files form folders on disk. The 
import command is found in the file menu and is active when entering the Reading Window. 

  

The operator clicks the file that should be imported and click the Open button.  
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Information from the file will automatically appear in the fields in the Reading window. The 
operator acts the same way as when register i normal reading.  

 How to do a reading. 

Service DisplayService DisplayService DisplayService Display 

     

The icon will not be visible on MATRIS Customer version. 

This will work as same as the Service Display. This function will work when the computer is 
connected to machine with the ignition key on and with the MATRIS cable part number 
9993892. 

To push on two buttons at the same time, use the drop down field for selection at Send switch 
combination: and click at the Send button. 

AlarmAlarmAlarmAlarm 

The alarm function can be used as a tool to find readings and presentations that for different 
reasons are extra interesting. It is for example possible to instruct MATRIS to generate an 
alarm when the fuel consumption of a machine reading rises above a certain limit. 
 
The alarm function is a powerful tool for supervision of a large amount of readings. The 
MATRIS application use customizable rules to browse through the reading database and 
highlight only the readings that fulfil certain conditions. The alarm function does the work. 
 
New Alarm RuleNew Alarm RuleNew Alarm RuleNew Alarm Rule 
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Follow the steps below to create a new alarm rule: 
1. Go to the Edit Alarm Rule function by clicking the edit button and choose “New” (or choose 
“Function” -> “New Alarm Rule”). 
2. Supply alarm name.  
3. Add the machines that will be watched by the alarm rule. It is possible to add one or many 
machines.  
4. Select the presentation that the alarm rule shall be based on. It is only possible to choose 
presentations that are common for all the selected machines. In general: The more machines 
that are included in the alarm, the fewer the presentations to select. 
5. Select alarm category (if it is needed). 
Select one of the displayed alarm levels (if it is needed). The alarm levels are based on the 
underlying presentation and are usually the same as a bar or a slice in a presentation. 
6. Add the trigger levels. The alarm will be triggered when the condition(s) are fulfilled. 
7. Click the save button. 
 
Edit Alarm RuleEdit Alarm RuleEdit Alarm RuleEdit Alarm Rule 
 
Follow the steps below to edit an alarm rule: 
1. Go to the Edit Alarm Rule function by clicking the edit button (or choose “Function” -> “Edit 
Alarm Rule”).  
2. Select the alarm rule to edit in list to the left. If the list is empty it means that there are no 
rules to edit. 
3. Change the information related to the selected alarm rule. 
4. Click the save button. 
 
To delete a rule: Select an alarm rule in the list to the left and click the delete button. Please 
note that it is also possible to set a rule as inactive. An inactive alarm rule can not be triggered 
until it is set as active again. 
 
View Triggered AlarmsView Triggered AlarmsView Triggered AlarmsView Triggered Alarms 
 
Follow the steps below to view triggered alarms: 
1. Click the view triggered alarm button or choose “Function” -> “View Triggered Alarm”. 
2. Click the calculate alarm button if alarm calculations are not performed automatically. All 
triggered alarms will then be listed to the left. (If the list is empty there are no triggered alarms.) 
3. Click a row in the list to the left to view the presentation that generated the alarm. 
 
When an alarm is selected it is possible to cross jump to the analysis function and analyse the 
rest of the reading. 

Network UpdateNetwork UpdateNetwork UpdateNetwork Update 
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Network Update (NU) is a standardised Volvo tool designed to download and manage update 
packages. The NU client tool is used by MATRIS and installed at setup from the MATRIS CD. 
 
When a new MATRIS update package is released it can be downloaded via the NU client. A 
MATRIS update package can include updates such as new presentations, support for new 
models, new application features, bug fixes and much more. It is recommended to download 
and install update packages when they are released. 
 
An Internet connection is needed in order to use the NU tool. It is only possible to download 
and install MATRIS update packages if the latest CD release is installed. A released CD can 
not be replaced by an update package. 
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